Warning: include() [function.include]: URL file-access is disabled in the server configuration in /home/avsforum/archive.tivocommunity.com/tivo-vb/history/archive_functions.php on line 31

Warning: include(http://archive.tivocommunity.com/tivo-vb/history/header.php) [function.include]: failed to open stream: no suitable wrapper could be found in /home/avsforum/archive.tivocommunity.com/tivo-vb/history/archive_functions.php on line 31

Warning: include() [function.include]: Failed opening 'http://archive.tivocommunity.com/tivo-vb/history/header.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/avsforum/archive.tivocommunity.com/tivo-vb/history/archive_functions.php on line 31
Pages:1



Constant Rebooting

(Click here to view the original thread with full colors/images)



Posted by: mehm

Last night when I got home, my tivo was running, but with audio only. The picture was completely black. I changed channels a few times, to no avail. The menu's, Now playing screen etc. were working correctly, so I went into system setup and tried to re-boot the machine. The re-boot reaches the point where it says "Almost there", then after about 15 seconds the screen flickers, and returns to the Powering up screen. I turned it off, and the next morning it booted to a black screen, audio only. Ever since, it does not boot anymore at all. In December, I upgraded the system with 2 120GB drives, and until now have had no problems. Thinking the problem was drive related, I dug up the original drive, and put it in, only to find that it does the same thing. Re-boot, Almost There, Reboot. Is there any way to get a better idea of what is going on ? Maybe see a bootup diagnostic screen or something ? Anyone have any Ideas ?

I want my tivo back!!!



Posted by: catrov

You don't say what model TiVo you have, how long you have had it before you upgraded it, and what possible causes you've tried isolating. My TiVo, a Pioneer 810H upgraded in February to 300 GB, started rebooting between once a day and once an hour about 2 weeks ago. I have tried testing various possible causes - 1) has the disk now filled up to the point that program buffers, main memory, or swap are overflowing when it tries to do certain operations to manage all that data? 2) Is it overheating because the weather is now warmer? 3) did I do the upgrade wrong, perhaps by not allocating enough/any swap, and now it's grown enough to trigger problems?

I took my disk out and copied off the log files. 'KERNEL' ends with the following entries:

Jun 5 08:32:09 (none) kernel: overrun
Jun 5 08:32:20 (none) last message repeated 7 times
Jun 5 08:32:23 (none) kernel: Bumping mpg321 priority up to 5
Jun 5 08:32:23 (none) kernel: Starting '/sbin/mpg321 -i -a /dev/brcmpcm1 -g 75 -T -G 10 -R xxx '
Jun 5 08:32:23 (none) kernel: ProcessRemoteFilterChanged db=2 cur=0
Jun 5 08:32:23 (none) kernel: ProcessRemoteFilterChanged saving cur=0
Jun 5 08:32:24 (none) kernel: ProcessRemoteFilterChanged db=0 cur=2
Jun 5 08:32:24 (none) kernel: ProcessRemoteFilterChanged saving cur=2
Jun 5 08:32:25 (none) kernel: overrun
Jun 5 08:32:28 (none) kernel: Initing
Jun 5 08:32:28 (none) kernel: cdrom: open failed.
Jun 5 08:32:29 (none) kernel: Running loop
Jun 5 08:32:30 (none) kernel: Scanning for phase4 repair scripts
Jun 5 08:32:30 (none) kernel: Running boot Stage G_PostApplication scripts
Jun 5 08:32:30 (none) kernel: rc.sysinit is complete
Jun 5 08:32:32 (none) kernel: overrun
Jun 5 08:33:16 (none) last message repeated 8 times
Jun 5 08:34:20 (none) last message repeated 17 times
Jun 5 08:35:21 (none) last message repeated 20 times
Jun 5 08:36:30 (none) last message repeated 22 times
Jun 5 08:37:36 (none) last message repeated 9 times
. . .
Jun 5 09:29:08 (none) last message repeated 68 times



Note that it had overruns mixed in before the final failure, and got an open error on the CD/ROM - I don't know if that's significant. Also I don't know what to make of the fact it took an hour to crash.

Also, earlier in the log it said:

Jan 2 00:00:38 (none) kernel: Starting kswapd
Jan 2 00:00:38 (none) kernel: Activating swap partitions
Jan 2 00:00:38 (none) kernel: Unable to find swap-space signature
Jan 2 00:00:38 (none) kernel: swapon: /dev/hda8: Invalid argument


but I had done the recommended restore commands with the swap arguments when building the expanded disk.

I don't understand MfsTools well enough to know what I can do to diagnose the current state of the swap partition, and could use some help from forum members as to what tools to use for this.

I also want my reliable TiVo back, not this flaky thing I have now!



Posted by: Gomer Pyle

A black screen doesn't sound drive related at all, obviously related to the video circuitry somehow...



Posted by: mehm

The device is a Series 2 Tivo, and was about 14 months old when I modified it. I have been using it modified for about 6 months. Where did you find the log files you talked about, and how do you know which files to look for ? Sounds like this could be just the sort of thing to shed some light on this problem.



Posted by: catrov

The log files are in /var/log on the TiVo disk. You can get a map of TiVo partitions by booting the MfsTools 2.0 disk (use the LBA48 version if it's a Pioneer DVD burner/TiVo) and doing:

tpip -p /dev/hdx

where x is chosen as appropriate for which IDE port you hooked the drive to. Mount the partition that tpip tells you /var is on. As to how I knew which log files - I just copied them off where I could look at them under Windows and started poking around. My problems are looking like I had no swap - log file 'MESSAGES' reported 0 swap available during boot-up. I fixed it with mkswap yesterday, and (cross my fingers) it hasn't rebooted again in 20 hours. I'm amazed it worked OK from mid-February until last month in that condition. I'll be interested to see if you have the same problem, especially after running for 6 months since upgrade.



Posted by: mehm

I hope to get a chance to try this tonight. Since the Tivo will not boot with the original drive, I have my doubts. It would be great if I could just figure out what the issue is that is causing it to fail to boot. If something is physically damaged, I will feel better about just getting a new unit. Maybe this time I will put an extra fan in the thing. With 2 drives, it seemed to get really hot. Even though the Info screen always said it was operating at a Normal temperature. When I finish, I will let you know what I discover.
Thanks for all the info.
Mike




Warning: include() [function.include]: URL file-access is disabled in the server configuration in /home/avsforum/archive.tivocommunity.com/tivo-vb/history/archive_functions.php on line 37

Warning: include(http://archive.tivocommunity.com/tivo-vb/history/footer.php) [function.include]: failed to open stream: no suitable wrapper could be found in /home/avsforum/archive.tivocommunity.com/tivo-vb/history/archive_functions.php on line 37

Warning: include() [function.include]: Failed opening 'http://archive.tivocommunity.com/tivo-vb/history/footer.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/avsforum/archive.tivocommunity.com/tivo-vb/history/archive_functions.php on line 37



vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Limited.
vB Easy Archive Final ©2000 - 2014 - Created by Stefan "Xenon" Kaeser Modified by Adam J. de Jaray