TiVo Community Forum Archive 1
READ ONLY ARCHIVES

Welcome to the TiVo Community Forum Archive
This archive covers threads on TiVo Community Forum that have not been posted to from the start until June 30, 2004.  Any thread that has a post made to it between 7/1/04 and 12/31/05, that had not been posted to, will be found in Archive 2.
This is a READ ONLY site.

  Search | ARCHIVE 2 | MAIN SITE

TiVo Community Forum Archive 1 : Powered by vBulletin version 2.2.8 TiVo Community Forum Archive 1 > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
>>> JavaHMO 1.1 for Mac OS X (beta) <<<

Pages (2): « Prev 1 [2]  
Forum Jump:
Search this Thread:
Last Thread   Next Thread
Author
Thread ---> Show Printable Version | Email this Page | Subscribe to this thread Post New Thread    Post A Reply
mattman is offline Old Post 01-05-2004 06:01 AM
Click Here to See the Profile for mattman Find more posts by mattman Add mattman to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
mattman
Deep In The Mattcave

Registered: Jun 2002
Location: Anchorage, AK
Posts: 164

Loki-

I know I would appreciate the ability to use AAC on my TiVo. If you could write a plugin, or whatever, that would be awesome. I have no real use for MFSTools, if I understand what it does, but I assume there are others who do.

Matt

__________________
1 TiVo Series 2 60 Hr
1 TiVo Series 2 40 Hr
Both connected through a Powerline Network to my wired and wireless network.

POST #21 | Report this post to a moderator | IP: Logged

bmodell is offline Old Post 01-10-2004 07:59 PM
Click Here to See the Profile for bmodell Find more posts by bmodell Add bmodell to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
bmodell
New Member

Registered: Jan 2004
Location: Spring grove Illinois
Posts: 2

I am dying here! how much longer before a more open beta??

__________________
Tivo Series 2 with 120gb Upg
Direct Tv Tivo Series 1
Linksys USB With HMO
Airport Wireless

POST #22 | Report this post to a moderator | IP: Logged

tefler is offline Old Post 01-13-2004 09:14 AM
Click Here to See the Profile for tefler Find more posts by tefler Add tefler to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
tefler
Member

Registered: Feb 2003
Location: MA
Posts: 77

Public Beta available

First, thanks to those who have helped test out this first betas. I hope that most of your feedback has been incorporated where appropriate. For everyone else, sorry for the delay in opening this up to everyone.

The latest beta has been uploaded to sourceforge, thanks to the main JavaHMO developer. This is available for download from:

http://prdownloads.sourceforge.net/...avaHMO-beta.dmg

This software requires that you are running 10.3.1 or later and have installed the Java Advanced Imaging (JAI) package from Apple.

Please note that this is a beta and as such it may or may not cause harm to your system. I've taken as much precaution to prevent that, but it has only been installed in a limited number of places.

It is recommended that you read all of the files that are within the disk image before installing. Most important are the ReadMe, Known Issues, and Documentation.

The current release of JavaHMO does not have an integration with the iTunes and iPhoto library like the TiVo Desktop does. This will hopefully be in a later release. For now, you can manually point it at the iTunes and iPhoto library directories (discussed in Known Issues document).

Feel free to post any issues you find here in this thread. As mentioned previously, my free time has shrunk since I started working on this. However, I will try to work on any issues that folks find as soon as I can. I am also working on getting a package together of the java source changes, control app source, and packaging scripts available to those who want to modify and built this themselves.

Last, this is merely a repackaging of the work done by the great folks who created JavaHMO. You can find the source code to JavaHMO and other various documentation at http://javahmo.sourceforge.net/.

If you have feature requests or comments on the JavaHMO functionality and not necessarily the OS X packaging and control application, it is probably best to post those in the other more general JavaHMO thread.

Thanks

POST #23 | Report this post to a moderator | IP: Logged

tefler is offline Old Post 01-13-2004 09:19 AM
Click Here to See the Profile for tefler Find more posts by tefler Add tefler to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
tefler
Member

Registered: Feb 2003
Location: MA
Posts: 77

Quick Note

I should also mention that in this beta, debug logging is turned on. If your logs are growing out of control, you can turn it off by editing /usr/share/javaHMO/conf/log4j.xml and changing:

<root>
<priority value="DEBUG"/>
<appender-ref ref="AsyncTrace"/>
</root>

To:

<root>
<priority value="INFO"/>
<appender-ref ref="AsyncTrace"/>
</root>

POST #24 | Report this post to a moderator | IP: Logged

cwoody222 is offline Old Post 01-14-2004 10:36 PM
Click Here to See the Profile for cwoody222 Find more posts by cwoody222 Add cwoody222 to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
cwoody222
TiVo Forum Special Member

Registered: Nov 1999
Location: Buffalo, NY
Posts: 2440

The first download I had wouldn't open. There was an error in the package. I picked another download location and got it and installed it. I rebooted my Mac and TiVo. JavaHMO won't start. It tells me the Admin Interface isn't ready. Help!


I also saw the Desktop screenshot doesn't work with Mac - is that going to come later?

__________________
--Chris

"whenever cwoody222 comes in and comments, it makes everything very clear" - drewman
"cwoody222 is so right-on it isn't funny" - esperantisto

POST #25 | Report this post to a moderator | IP: Logged

bedelman is offline Old Post 01-15-2004 03:10 AM
Click Here to See the Profile for bedelman Visit bedelman's homepage! Find more posts by bedelman Add bedelman to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
bedelman
Call me Bob

Registered: Feb 2001
Location: Lakewood, IL, USA
Posts: 2638

quote:
Originally posted by cwoody222
The first download I had wouldn't open. There was an error in the package. I picked another download location and got it and installed it. I rebooted my Mac and TiVo. JavaHMO won't start. It tells me the Admin Interface isn't ready. Help!
Did you turn off TiVo Desktop? On some machines it can take a while (2 minutes or so) for JavaHMO to start up -- using the "Refresh" button in the control application appears to make it start over if you use it too soon (at least in my case). Do you have the auto-start enabled?

By the way, use the following paths for your Music and Photos settings (assuming the files are in their "normal" locations (put them in with your home folder name in the place of the xxxxxxxx below)...

Music -- > /Users/xxxxxxxx/Music/iTunes/iTunes Music
Photos --> /Users/xxxxxxxx/Pictures/iPhoto Library/Albums

__________________
Bob Edelman

1 Pioneer DVR-810H
2 TiVo Series 2 80 hour (one living with son in college)
1 TiVo Series 2 140 hour
1 Humax DRT-800 DVD Recorder with TiVo
1 Sony SVR-2000 (living with other son in Michigan)

POST #26 | Report this post to a moderator | IP: Logged

tefler is offline Old Post 01-15-2004 03:56 AM
Click Here to See the Profile for tefler Find more posts by tefler Add tefler to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
tefler
Member

Registered: Feb 2003
Location: MA
Posts: 77

quote:
Originally posted by cwoody222
The first download I had wouldn't open. There was an error in the package. I picked another download location and got it and installed it. I rebooted my Mac and TiVo. JavaHMO won't start. It tells me the Admin Interface isn't ready. Help!


I also saw the Desktop screenshot doesn't work with Mac - is that going to come later?



I haven't been able to get the Desktop screenshot to work without breaking other things. I may eventually solve that, but isn't high on the priority list.

Did you disable the normal TiVo Desktop first?

Please take a look at the logs to see if any errors are mentioned.

POST #27 | Report this post to a moderator | IP: Logged

cwoody222 is offline Old Post 01-15-2004 04:28 AM
Click Here to See the Profile for cwoody222 Find more posts by cwoody222 Add cwoody222 to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
cwoody222
TiVo Forum Special Member

Registered: Nov 1999
Location: Buffalo, NY
Posts: 2440

OK, I got it semi-working. I uninstalled the one I installed this morning and started over. Plus I forgot to disable the normal TiVo Desktop. That solved it.

But I can't seem to get my iTunes Music or Playlists to come up. Or Shoutcast.

I have tried various ways of typing in my Music location. Should I point to the folder that has all my music (I use iTunes to organize my music so that folder has folders for each artist)?

Where am I supposed to point the Playlist to?

Shoutcast has nothing to do with iTunes though, does it? So I'm wondering why that one isn't working. I just get a message that I'm not sharing any music.

__________________
--Chris

"whenever cwoody222 comes in and comments, it makes everything very clear" - drewman
"cwoody222 is so right-on it isn't funny" - esperantisto

POST #28 | Report this post to a moderator | IP: Logged

cwoody222 is offline Old Post 01-15-2004 04:40 AM
Click Here to See the Profile for cwoody222 Find more posts by cwoody222 Add cwoody222 to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
cwoody222
TiVo Forum Special Member

Registered: Nov 1999
Location: Buffalo, NY
Posts: 2440

OK, update. I got Audio to work. I think I didn't Apply the changes. But my Playlists and Shoutcast are still no goes.

__________________
--Chris

"whenever cwoody222 comes in and comments, it makes everything very clear" - drewman
"cwoody222 is so right-on it isn't funny" - esperantisto

POST #29 | Report this post to a moderator | IP: Logged

tefler is offline Old Post 01-15-2004 06:00 AM
Click Here to See the Profile for tefler Find more posts by tefler Add tefler to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
tefler
Member

Registered: Feb 2003
Location: MA
Posts: 77

quote:
Originally posted by cwoody222
OK, update. I got Audio to work. I think I didn't Apply the changes. But my Playlists and Shoutcast are still no goes.


What kind of playlists are you trying to get working? JavaHMO does not currently see iTunes playlists.

As for shoutcast, I have found that to be a hit or miss thing. Try a bunch of them and you will probably see one that works. This is discussed in the main JavaHMO thread in this forum.

POST #30 | Report this post to a moderator | IP: Logged

cwoody222 is offline Old Post 01-15-2004 06:21 AM
Click Here to See the Profile for cwoody222 Find more posts by cwoody222 Add cwoody222 to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
cwoody222
TiVo Forum Special Member

Registered: Nov 1999
Location: Buffalo, NY
Posts: 2440

Yep, I was trying iTunes. Didn't know those didn't work

__________________
--Chris

"whenever cwoody222 comes in and comments, it makes everything very clear" - drewman
"cwoody222 is so right-on it isn't funny" - esperantisto

POST #31 | Report this post to a moderator | IP: Logged

tefler is offline Old Post 01-15-2004 06:42 AM
Click Here to See the Profile for tefler Find more posts by tefler Add tefler to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
tefler
Member

Registered: Feb 2003
Location: MA
Posts: 77

quote:
Originally posted by cwoody222
Yep, I was trying iTunes. Didn't know those didn't work


You can find a list of known issues in the 'Known Issues' document that is part of the disk image you downloaded. There are a few small gothcas that will hopefully be addressed over time.

POST #32 | Report this post to a moderator | IP: Logged

javahmo is offline Old Post 01-15-2004 07:44 AM
Click Here to See the Profile for javahmo Visit javahmo's homepage! Find more posts by javahmo Add javahmo to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
javahmo
Advanced Member

Registered: Aug 2003
Location: Nashua, NH
Posts: 528

One of the JavaHMO users is currently working on adding support for iTunes playlists.

__________________
javahmo.sourceforge.net
javahmo at users.sourceforge.net

POST #33 | Report this post to a moderator | IP: Logged

bmodell is offline Old Post 01-16-2004 04:08 AM
Click Here to See the Profile for bmodell Find more posts by bmodell Add bmodell to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
bmodell
New Member

Registered: Jan 2004
Location: Spring grove Illinois
Posts: 2

Just a thank you

Just want to thank all of these involved in the JavaHMO project, as well as those working on the OS X Port.

You guys have done a good job.. keep up the good work!

__________________
Tivo Series 2 with 120gb Upg
Direct Tv Tivo Series 1
Linksys USB With HMO
Airport Wireless

POST #34 | Report this post to a moderator | IP: Logged

elricofmelnibone is offline Old Post 01-22-2004 09:45 AM
Click Here to See the Profile for elricofmelnibone Find more posts by elricofmelnibone Add elricofmelnibone to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
elricofmelnibone
New Member

Registered: Jan 2004
Location:
Posts: 1

Question Audio Library "path" problems

First let me say that I am not very knowledgeable about unix at all but I can usually figure things out. This has me stumped.

My Itunes music is not in the standard location. I have a firewire HDD named "MP3" with all of my music on it. It is mounted under Jonathan McKay's Computer as MP3/iTunes Music/.

Audio works fine when using the TiVo desktop.

I cannot get the path in the javaHMO audio configuration to work. Every different format I have tried gives me a java error message of "invalid path."

(/Volumes/MP3/iTunes Music)

Can anyone help with this?

Thanks in advance.

Emac G4 700
OS X ver 10.3.2
Toshiba Media Server series 2 TiVo with HMO

POST #35 | Report this post to a moderator | IP: Logged

bedelman is offline Old Post 01-22-2004 12:39 PM
Click Here to See the Profile for bedelman Visit bedelman's homepage! Find more posts by bedelman Add bedelman to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
bedelman
Call me Bob

Registered: Feb 2001
Location: Lakewood, IL, USA
Posts: 2638

You can use the "Go to folder" function under the "Go" menu in finder to check your paths. Type in the path and if it works to open the appropriate folder, the path is correct.

__________________
Bob Edelman

1 Pioneer DVR-810H
2 TiVo Series 2 80 hour (one living with son in college)
1 TiVo Series 2 140 hour
1 Humax DRT-800 DVD Recorder with TiVo
1 Sony SVR-2000 (living with other son in Michigan)

POST #36 | Report this post to a moderator | IP: Logged

mac_media is offline Old Post 01-23-2004 10:23 AM
Click Here to See the Profile for mac_media Find more posts by mac_media Add mac_media to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
mac_media
New Member

Registered: Jan 2004
Location: New York
Posts: 4

Just wanted to let whoever is interested that I've got JavaHMO working just fine. I'm running it on an iBook across a wireless/wired network. Prety much all the functionality is there. Thanks for all your efforts on this program!

POST #37 | Report this post to a moderator | IP: Logged

cwoody222 is offline Old Post 01-24-2004 08:01 AM
Click Here to See the Profile for cwoody222 Find more posts by cwoody222 Add cwoody222 to your buddy list Show Printable Version Edit/Delete Message Reply w/Quote
cwoody222
TiVo Forum Special Member

Registered: Nov 1999
Location: Buffalo, NY
Posts: 2440

Yep, JavaHMO worked fine for me once I got it up and running. Was really hoping for the desktop and Streamcast features though

But hey, it's free!

__________________
--Chris

"whenever cwoody222 comes in and comments, it makes everything very clear" - drewman
"cwoody222 is so right-on it isn't funny" - esperantisto

POST #38 | Report this post to a moderator | IP: Logged

All times are GMT. The time now is 02:38 AM. Post New Thread    Post A Reply
Pages (2): « Prev 1 [2]   Last Thread   Next Thread
>>> JavaHMO 1.1 for Mac OS X (beta) <<<

TiVo Community Forum Archive 1 : Powered by vBulletin version 2.2.8 TiVo Community Forum Archive 1 > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
Search The Internet
 
Show Printable Version | Email this Page | Subscribe to this thread

Forum Jump:
 
Search this Thread:

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are ON
[IMG] code is ON
 

< Contact Us - TiVo Community Forum Archive 1 >

Powered by: vBulletin Version 2.2.8
Copyright ©2000, 2001, Jelsoft Enterprises Limited.
(C)opyright - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not affiliated with TiVo Inc.
Page generated in 0.06789589 seconds (87.22% PHP - 12.78% MySQL) with 20 queries.


Spider History Index